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1 概要 
Mascot Daemon は Mascot 検索プロセスの自動化を支援する、Mascot Server のクライアントソフトウエアです。次の動作     

モードをサポートしています。 

(1) バッチ・モード（Batch） 

複数の質量データファイルに対して逐一 Mascot 検索を実行します。検索開始日時や、task 間で順序よく実行させるように指

定することもできます。 

(2) リアルタイムモニター・モード（Real-time monitor） 

指定したフォルダ(ローカルあるいはネットワーク上)を監視し、そのフォルダ内に新たに作成された質量データファイルを取得

して、Mascot 検索を実行します。 

(3) フォローアップ・モード（Follow-up） 

検索結果のスコアあるいは期待値が、あらかじめ指定したそれらの数値に達しなかった場合、別の検索条件を使って自動的

に再検索を実行します。定期的に更新される配列データベースに対して自動的に再検索を実行させることもできます。 

1.1 タスク 

Mascot Daemon は検索を「タスク」単位で管理します。タスクは次の６つの情報で構成されています。 

(1) タスク名 

(2) 検索条件 (検索条件ファイル「*.par」ファイルとして前もって作成) 

(3) 質量データファイル (生の質量データファイルの場合はフィルタプログラムを指定) 

(4) 検索の実行時期 

(5) 再検索条件 (Follow-up の条件) 

(6) 外部プログラムの起動 (検索結果の Auto-export 機能、External processes 機能のサポート) 

タスクは４つの状態（実行中：Running、中断：Paused、完了：Completed、キャンセル：Canceled）で表現されています。Paused 

タスクは再実行（Resume）することができます。Paused タスクと Completed 状態のタスクはキャンセルまたは削除することが    

できます。 

1.2 フィルタプログラム（Data Import Filters） 

Mascot Daemon はテキスト形式のピークリストファイルおよび生の質量データファイルをサポートしています。テキスト形式の  

ピークリストファイル（たとえば MGF ファイル）は特別な処理をせずにそのまま Mascot Server に投入することができますが、raw 

データについては、対応するフィルタプログラムを利用してピーク抽出処理を行い、Mascot Server に投入できるピークリスト     

ファイル（たとえば MGF ファイル）を作成する必要があります。Mascot Daemon は Mascot Distiller および Windows のコマンド

ラインで実行できるフィルタプログラムをサポートしています。 

主な実行可能なプログラムは以下の通りです。 

(1) Mascot Distiller：http://www.matrixscience.com/distiller.html 

全ての質量分析計ベンダーの生の質量データファイルを処理することができます。別途ライセンスが必要です。 

(2) ProteoWizard MSConvert：http://proteowizard.sourceforge.net/downloads.shtml 

さまざまな質量データフォーマットに対応しています。詳細は http://proteowizard.sourceforge.net/doc_users.html の

Supported format をご覧ください。 
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(3) Thermo ExtractMSn 

Thermo Fisher Scientific 社が提供する Xcalibur RAW ファイル処理プログラムです。すでにプログラムの開発・保守は 

終了しており、基本的に古い機種のデータのみ対応しています。 

(4) AB Sciex MS Data Converter：http://www.absciex.com/software-downloads-x2110 

AB Sciex 社が提供するプログラムです。Wiff ファイルおよび TOF/TOF データファイルを処理することができます。 

(5) その他:フィルタプログラムの追加 

Windows のコマンドラインから実行できるプログラムであれば Mascot Daemon の[Data import filer]リストに追加する

ことができます。詳しくは Mascot Daemon のソフトウェア内にあるヘルプ[menu の help ->Mascot Daemon Help]に

て、In depth→Data Import Filters →「Adding a new filter」の項目をご覧ください。 

1.3 運用形態 

ひとつの Mascot Server に対し、複数の Mascot Daemon を利用することができます。たとえば、複数の質量分析計を

お持ちの場合、それぞれの質量分析計のために用意されたPCにMascot Daemonをインストールすることもできますし、

研究者が所有する PC に Mascot Daemon をインストールし、複数の質量分析の raw ファイルを一元的に処理することも

できます。 

1.4 他のプログラムとの連携 

External processes 機能を使うことにより、タスク開始前後および Mascot 検索実行前後のタイミングで外部のプログ

ラムを実行することができます。詳しくは Mascot Daemon のソフトウェア内にあるヘルプ[menu の help ->Mascot 

Daemon Help]にて、In depth→Reference →「External Processes Dialog」の項目をご覧ください。 
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2 インストールと環境設定 

2.1 動作環境 

Mascot Daemon は、 

・Windows Vista SP2 あるいは Server 2008 SP2 以上  (但し新規インストールの場合は基本的に Windows10 のみ推奨) 

・Microsoft .NET framework 4.6 以上 

・Distiller ご利用の場合、Distiller のバージョンは 2.6 以上であること 

の動作環境を持った PC にインストールすることができます。Mascot Daemon は HTTP プロトコルを利用して Mascot Server と

通信しますが、弊社がインターネット上で公開している Mascot Server（http://www.matrixscience.com/cgi/）を利用する事はで

きませんのでご注意ください。 

2.2 新規インストール 

Mascot Daemon をインストールする前に、Mascot Server が正しく動作していることを確認してください。また、Mascot Server

と同じバージョンの Mascot Daemon をインストールしてください。インストール作業は数分で終了します。 

(1) Mascot Daemon をインストールしたい PC の Web ブラウザから Mascot 検索を実行し、Mascot Server が正しく動作する

事を確認してください。もし Mascot Server が正しく動作しない場合は、この問題を解決した後に、Mascot Daemon を   

インストールしてください。 

(2) Web ブラウザを起動し、Mascot Server の「Welcome」トップページ「http://ホスト名/mascot/」にアクセスしてください。 

(3) 「Welcome」トップページの中程にある「Mascot Daemon」項の[Install]リンクをクリックしてください。「Installing Mascot 

Daemon」ページが表示されます 

 

(4) 項目「3.」の[setup]リンクをクリックすると Mascot Daemon のインストーラーである「daemon_setup.exe」が「C:¥Users¥ユ

ーザ名¥Downloads」フォルダにダウンロードされます。インストーラーをダブルクリックで実行すると「Setup Wizard」が起

動します。表示されるダイアログの内容に従って インストールを進めてください。なお、Microsoft .NET framework がイン

ストールされていない場合はその旨のメッセージが表示されますので、そのまま指示に従うか、あるいは次に示すリンクから

ダウンロードしてインストールし、再度「daemon_setup.exe」を実行してください。 

 

▶ Microsoft .NET framework 4.6： 

https://www.microsoft.com/en-gb/download/details.aspx?id=48130 

 

 

 

z 
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(5) 使用許諾契約書をお読みいただき、同意の上「I accept the 

agreement 」 に チ ェ ッ クを 入れ て 「 Next 」 に 進 ん で        

ください。 

 

 

 

 

 

 

(6) Mascot Daemon をどのフォルダにインストールするか設定

してください。 

 

 

 

 

 

 

 

(7) デスクトップ上に Mascot Daemon のショートカットを 

設置するかどうか選択してください。 

 

 

 

 

 

 

 

(8) インストール前に設定の確認が入ります。 

問題なければ「Install」に進んでください。 
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(9) インストールが終了し、[Launch Mascot Daemon]にチェック

が入った状態で[Finish]ボタンを押すと、Mascot Daemon

が自動的に起動し、右図に示す[Preferences]ダイアログの

[Intranet]タブが表示されます。自動的に起動しない場合

は、 [スタート ]→  [Mascot Daemon]を選択し、Mascot 

Daemon を起動してください。[Mascot Server URL, up to 

and including cgi directory]入力欄に Mascot Server の

URL（http://ホスト名/mascot/cgi/）を入力し、[Save]ボタ

ンを押してください。Mascot Server との接続が確立され

ると Mascot Daemon の再起動を促されますので、Mascot 

Daemon を再起動してください。 

 

 

 

 

 

 

 

 

(10) Mascot Daemonを再起動すると、右図に示すウインドウが

表示されます。これで Mascot Daemon のインストール作

業は終了です 

 

 

 

 

 

 

 

2.3 アップグレード 

Mascot Daemon と Mascot Server は対になって動作しますので、互いに同じバージョンであることが必要です。Mascot Server

をアップグレードして正しく動作することを確認した後に、Mascot Daemon のアップグレード作業を行ってください。 

(1) 既存の Mascot Daemon が格納されている「C:¥Program Files¥Matrix Science¥Mascot Daemon」フォルダを        

バックアップしてください。 

(2) Windows の[スタート]→[コントロールパネル]→[プログラム]→[プログラムと機能]から既存の Mascot Daemon を       

アンインストールしてください。 
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(3) ¥Web ブラウザを起動し、Mascot Server の「Welcome」トップページ「http://ホスト名/mascot/」にアクセスし、ページの 

中程にある「Mascot Daemon」項の「Upgrade」リンクをクリックしてください。「Upgrading Mascot Daemon」ページが  

表示されます。 

 

 

 

(4) 項目「2.」の setup リンクをクリックすると Mascot 

Daemon の イ ン ス ト ー ラ ー で あ る

「 daemon_setup.exe 」 が 「 C:¥Users¥ ユ ー ザ 名

¥Downloads」フォルダにダウンロードされます。それ

を実行すると、右図のような「Setup Wizard」が起動し

ますので、表示されるダイアログの内容に従って  イン

ス ト レ ー シ ョ ン を 進 め て く だ さ い 。 な お 、

Microsoft .NET framework がインストールされてい

ない場合はその旨のメッセージが表示されますので、

指示に従ってインストールを行うか、次に示すどちらか

のリンクからダウンロードしてインストールし、 再度

「daemon_setup.exe」を実行してください。 

▶ Microsoft .NET framework 4.6： 

https://www.microsoft.com/en-gb/download/details.aspx?id=48130 

 

(5) インストールが終了して [Finish]ボタンを押すと、

Mascot Daemon は自動的に起動し、右図に示す

[Preferences] ダ イ ア ロ グ の [Intranet] タ ブ が 表 示    

さ れ ま す 。 自 動 的 に 起 動 し な い 場 合 は 、          

[ ス タ ー ト ] → [Mascot Daemon] を 選 択 し 、      

Mascot Daemon を 起 動 し て く だ さ い 。       

[Mascot Server URL, up to and including directory]

入 力 欄 に Mascot Server の URL           

（ http:// ホ ス ト 名 /mascot/cgi/ ） を 入 力 し 、    

[Save]ボタンを押してください。Mascot Server との 

接続が確立されると Mascot Daemon の再起動を   

促されますので、Mascot Daemon を再起動してくださ

い。 

 

(6) Mascot Daemon を再起動すると、右図に示すウインドウが 

表示されます。これでインストール作業は終了です 

 

 

 

 

 

 

 

 

http://%E3%83%9B%E3%82%B9%E3%83%88%E5%90%8D/mascot/%E3%80%8D%E3%81%AB%E3%82%A2%E3%82%AF%E3%82%BB%E3%82%B9%E3%81%97%E3%80%81%E3%83%9A%E3%83%BC%E3%82%B8%E3%81%AE
http://%E3%83%9B%E3%82%B9%E3%83%88%E5%90%8D/mascot/%E3%80%8D%E3%81%AB%E3%82%A2%E3%82%AF%E3%82%BB%E3%82%B9%E3%81%97%E3%80%81%E3%83%9A%E3%83%BC%E3%82%B8%E3%81%AE
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2.4 変換プログラム :ProteoWizard のインストール方法 

Mascot Daemon がインストールされている PC に、公開されている raw データ変換プログラム ProteoWizard msConvert が  

インストールされていると、様々なフォーマットの質量データファイルを処理することができます。以下、プログラムの入手並びに

Daemon で使用する手順についてご案内します。 

 

 

(1) Web ブラウザを起動して、 

「http://proteowizard.sourceforge.net/download.html」にア

クセスし、お客さまの環境にあった Platform の ProteoWizard

をダウンロードし、実行してください。 

 

 

 

 

 

 

 

 

 

(2) [Install for all users of  this machine]を選び、[Next]を

押してください。 

 

 

 

 

 

 

 

 

 

 

(3) インストール先のフォルダを指定し、[Next]を押してくださ

い。 

 

 

 

 

 

 

 

 

 

 

 

 

http://proteowizard.sourceforge.net/download.html
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(4) ファイルを右クリックしたときに ProteoWizard と関連付ける

かの設定が出ます。必要に応じて選択し、[Next]を押して   

ください。 

 

 

 

 

 

 

 

(5) [Install]を押してインストールを実行してください。完了したら

[Finish]を押してください。 

 

 

 

 

 

 

 

 

 

(6) Mascot Daemon のメニューバー[Edit]→[Preferences]から

[Data import filters]を選択し、[Full path to ProteoWizard 

msConvert]の項目に、インストールした ProteoWizard の

msConvert.exe のフォルダパスを入力してください。

[Browse]で選択することもできます。入力したら[Save]ボタン

を押してください。Mascot Daemon の再起動を促されますの

で、Mascot Daemon を再起動してください。 

 

 

 

 

2.5 ライセンスの使用許諾 

Mascot Daemon は Mascot Server にバンドルされたソフトウェアです。Mascot Server ライセンスをお持ちのお客様は、お客様

が所有している任意の PC に Mascot Daemon をインストールすることができます。 

 

2.6 アンインストール 

(1) [スタート]→[コントロールパネル]→[プログラム]→[プログラムと機能]を選択してください。現在インストールされている   

プログラムがリスト表示されます。 

(2)リストから[Mascot Daemon version 2.8.*]を選択して右クリックし、[アンインストール]を選択してください。 
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3 チュートリアル 
Mascot Daemon を利用した Mascot 検索の流れは、Web ブラウザを利用した Mascot 検索の流れと基本的に同じです。 

(1) 検索条件を設定し、 

(2) 質量データファイルを指定して Mascot 検索を実行し、 

(3) 必要に応じて Mascot 検索の進捗状況を確認し、 

(4) 検索終了後に検索結果を閲覧する。 

という流れになります。ここでは、Thermofisher Scientific 社の raw データを、MASCOT Daemon と ProteoWizard の変換プロ

グラムを使って検索する方法についてご案内します。raw データは、1 サンプル由来から複数の raw ファイルが作成されていて、検

索時にそれらのファイルを結合して検索する操作を想定しています。 

3.1 Mascot Daemon の起動 

デスクトップにあるショートカットをダブルクリックする

か、[スタート]→[Mascot Daemon]で Mascot Daemon

を起動してください。、図 3-1 に示すウインドウが表示され

ます。 Mascot Daemon のウインドウは４つのタブ

([Parameter Editor] 、 [Task Editor] 、 [Event Log] 、

[Status])と３つのメニュー([File]、[Edit]、[Help])から構

成されています。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

図 3-1 Mascot Daemonの起動画面 



Mascot Daemon 2.8 取扱説明書 | 12 
  

                                            
マトリックスサイエンス株式会社 

3.2 検索条件ファイルの作成 

一番右にある[Parameter Editor]タブをクリックしてください。図 3-2 のように、Web ブラウザに表示される検索条件設定画面

と同じような画面に切り替わります。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

ここで検索条件を設定し、検索条件ファイル(拡張子「.par」を持ったテキストファイル)として保存します。 

このチュートリアルでの検索例は raw ファイルを変換して検索を実行する例を想定していますが、具体的なデータを想定したもの

ではありません。データにより設定するべきパラメータの内容は様々ですが、１つの例として設定項目をご紹介します。実際にお手元

のデータを解析する場合は、測定内容にあったパラメータを選択してください。ただし選択内容がわからない時は、以下設定内容と

同じ内容を指定して検索を行い、結果をもとに設定内容について検討してください。 

 

[Database] →「SwissProt」を選択 

[Enzyme] →「Trypsin」を選択 

[Peptide tol. ±] →「0.1」を入力、「Da」を選択   (* 実際のデータに合わせて数値を変更してご利用ください) 

 [Enzyme] →「Trypsin」を選択 (* 実際のデータに合わせて数値を変更してご利用ください) 

[Fixed modifications] →「Carbamidemethyl(C)」を選択   (* 実際のデータに合わせて内容を変更してご利用ください) 

[Variable modifications] →「Oxidation(M)」を選択  (* 実際のデータに合わせて内容を変更してご利用ください) 

[MS/MS tol. ±] →「0.1」を入力、「Da」を選択  (* 実際のデータに合わせて数値を変更してご利用ください) 

[Instrument] →「Default」を選択 

[Decoy] →チェックを入れる 

[Target PSM FDR] →「1%」を選択 

その他、Taxonomy, Max.missed cleavages, #13 といった項目はデータに応じて変更する事をお勧めします。 

 

[Save As …]ボタンを使って、「tutorial01.par」というファイル名で設定内容をファイルに保存してください。 

 

図 3-2 Parameter Editor画面 
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3.3 タスクの作成と実行 

Mascot Daemon では、検索の単位をタスクとして定義します。[Task Editor]タブでタスクを指定します。タスクは

次の７つの項目で構成されています。 

(1) Task: タスク名 

(2) Parameter set : 検索条件 (「*.par」ファイルとして作成) 

(3) Data file list : 検索対象のファイル。テキスト変換後のピークリストファイルまたは raw データ 

(4) Data import filter :フィルタプログラム。必要に応じて”Options”も指定。 

(5) Schedule :  検索の実行時期。検索順番など検索実行タイミングなども指定 

 (6) Actions : 外部プログラムの実行、結果の CSV ファイル出力 

(7) Follow-up : Schedule で”Follow up”を選択したときの、継続条件 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

図 3-3 を参照しながら、次の内容を持つタスクを定義してください。 

(1) Task: Tutorial01 Search 

(2) Parameter set : 「…」をクリックして tutorial01.par を選択 (自動で入力されている事もあります) 

(3) Data file list : 検索対象のファイルを指定。[テキスト変換後のピークリストファイルまたは raw データを選びます] 

(4) Data import filter :”ProteoWizard msConvert”選択、さらに”Options”で”Peak list format”で”MGF”を選択 

(5) Schedule :“Start now”選択。その他、時間指定:”Start at” やフォルダ内の新ファイルを逐次検索”Real-time monitor”など 

 (6) Actions : 特に変更なし。結果の CSV 出力を希望する場合、”Auto-export”ボタンを押して設定してください。 

(7) Follow-up : 特に変更なし。 

* 画面左下”Merge MS/MS files into single search”にチェックを入れると、指定した raw ファイルを変換後すべて１つのファイ

ルにまとめて MASCOT 検索を行います。 

図 3-3 Task Editor 画面 
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パラメータをすべて選択後、”Run”ボタンを押すと検索が開始されます。ボタンを押すと図 3-4 に示す[Status]タ

ブに切り替わります。実行されたタスクが新しいタスクとして認識されるまではタスク名の前に砂時計が表示され

ます。検索が開始されると時計マークが表示され、Status 欄には先ほど開始したタスクが表示されます。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

[Status]タブの中では、タスクの状態を示すために、

図 3-5 に示すアイコンが使われます。 

リアルタイムモニター・モードでは、常に新しい質量

データファイルを待ち受ける（アイドリング）状態にあり

ますので、タスクは完結せず、常に砂時計アイコンが 

表示されます。 

動作中のタスクは中断させることができます。また、

完結したタスクと中断したタスクは削除することがで

きます。タスク名をクリックして選択すると[Status]  

タブ下方にあるボタンがアクティブになりますので、 

処理したい内容に対応するボタン（[Pause]、[Resume]、[Clone]、[Cancel]、[Delete]）を押してください。[Clone]  

ボタンを押すと、そのタスクが「Copy of  タスク名」として複製され、[Task Editor]タブに表示されます。[Status]タブ

の [Delete]ボタンを使ってタスクを削除しても、それに対応する Mascot Server 上の検索結果ファイル

（C:¥inetpub¥mascot¥data¥yyyymmdd¥Fxxxxxx.dat）は削除されません。Mascot Daemon の Task database  

ファイル（C:¥ProgramData¥Matrix Science¥Mascot Daemon¥taskdb.vdb5）からそのタスクと関連情報エントリ

が削除されるだけです。検索結果は Mascot Server 上に残り、Mascot search log ページからいつでも参照すること

ができます。なお、タスク名を右クリックしても上記と同じ内容の操作を行うことができます。 

 

 

 

 

 

図 3-4 [Status]タブと検索中を示す時計マークのタスク 

図 3-5 タスクの状態を示すアイコンの意味 

時計アイコン：動作中(検索中)のタスク 

鎖アイコン：Follow-upタスク 

砂時計アイコン：タスクの中断処理中 

チェックアイコン：完結したタスク 

バッテンアイコン：キャンセルされたタスク 

中断アイコン：中断したタスク 
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検索の進捗状況は、図 3-6 に示すように  ”Event Log”タブで確認する事ができます。このログは

「C:¥ProgramData¥Matrix Science¥Mascot Daemon¥Mascot_Daemon_Event_Log.csv」ファイルに記録されて

います。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3.4 検索結果の表示 
 

検索が終了すると、図 3-4 の[Status]タブの内容は図 3-7 の ようになります。タスク名の前には検索が終了したことを示す緑の

チェックマーク(✓)が表示されます。チェックマーク左の＋ マーク（タスクノードと呼びます）をクリックすると、検索時のファイル、 

またはファイルを結合した場合は”mascot_daemon_merge.mgf”というフォルダマークのアイコンが表示されます。アイコンを   

クリックすると、右側ウインドウに検索結果の概要が表示されます。 

[Result file URL] 欄に表示されている URL は Mascot Server 上に保存された検索結果ファイルが指定されており、そこをクリ

ックすると Web ブラウザが起動し、対応する検索結果ページが表示されます。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

図 3-6 [Event Log]タブ 

図 3-7 [Status]タブと検索結果の概要表示 
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4 リファレンス 

以降、ソフトウェアで選択できる項目について説明いたします。 

 

4.1 メニュー 

 
(1) [File]メニュー 

次の[Exit]以外のコマンドは[Parameter Editor]タブを開いてい

るときに有効です。また、[Parameter Editor]タブにも同じ機能の

ボタンが配置されています。 

[New …] 

検索条件の設定をデフォルトに戻します。 

[Open …] 

検索条件ファイルの読み込みダイアログを表示します。 

[Save] 

読み込まれている検索条件ファイルに現在の検索条件を上書き保存します。 

[Save As …] 

検索条件ファイル名を指定して現在の検索条件を保存します。 

[Exit] 

Mascot Daemon GUI を終了します。この操作では Mascot Daemon Engine プログラムは停止しません。Mascot Daemon 

Engineプログラムを終了したい場合は、Windowsのタスクトレーにある歯車アイコンを右クリックして[Exit]を選択してください。 

 

(2) [Edit]メニュー 
[Cut]から[Clear]までのコマンドは[Parameter Editor]タブあるいは[Task Editor]タブを開いているときに有効です。 

[Cut] 

選択したテキストをクリップボードにコピーした後に削除します。 

[Copy] 

選択したテキストをクリップボードにコピーします。 

[Paste] 

クリップボードのテキストをカーソル位置に挿入します。または選択したテキストを置き換えます。 

[Clear] 

選択したテキストを削除します。 

[Preferences] 

[Preferences]ダイアログを表示します。 

[ODBC Information …] 

現在使用しているタスク・データベース ODBC connection の詳細を示すダイアログを表示します。 

[Refresh] 

[Status]タブの表示内容を更新します。 

図 4-1 メニュー 
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(3) [Help]メニュー 

[Mascot Daemon Help …] 

オンラインヘルプを表示します。 

[Register Mascot Distiller] 

Mascot Distiller の Mascot Daemon 接続モジュール・ライセンスを登録する際に使用します。登録には弊社が発行したシリア

ル番号が必要になります。 

[About …] 

Mascot Daemon のバージョンをチェックすることができます。 

4.2 [Preferences]ダイアログ 

[Preferences]ダイアログの中で使われる値はグローバルな設定値として Windows OS のレジストリに保存されるため、値を変更

した場合は Mascot Daemon（GUI および Engine）を再起動する必要があります。 

(1) [Intranet]タブ 

Mascot Daemon と接続する Mascot Server の URL を入力して

ください。指定した Mascot Server に接続できない場合は warning

メッセージが表示されます。なお、弊社がインターネット上で公開し

ている Mascot Server の URL は使えません。 

Web サーバがユーザ名とパスワードを要求する設定になっている

場合は、これらの情報を [Authentication]タブの [Web Server 

Authentication]欄に入力してください。 

Mascot Daemon と Mascot Server を接続するための４つの

HTTP 関連の設定値は、通常デフォルト値で問題ありません。[HTTP 

access type]として[Proxy server]を選択した場合は[HTTP proxy 

server]欄に HTTP プロキシサーバの URL を入力してください。

[HTTP timeout(seconds)]の値は、設定ファイルなどの小さなファ

イルを転送する際に使われます。大きなサイズの質量データファイルのアップロードや検索結果レポートのダウンロードに対する 

timeout 設定は Mascot Daemon のプログラム内に書き込まれています。 

Mascot Daemon と Mascot Server 間に認証が必要な Proxy server が存在する場合は「HTTP/1.0」を選択してください。 

(2) [Data import filters]タブ 

[Root folder for files cached by data import filters]入力欄に

はタスクに関係するファイル（ピークリストファイル、Mascot Distiller

のプロジェクトファイル、検索結果の CSV 出力ファイルなど）を格納

するフォルダパスを指定してください。 

「Thermo ExtractMSn」、「AB SCIEX MS Data Converter」、

「ProteoWizard msConvert」の３つのフィルタプログラムを標準で

サポートしていますので、これらのフィルタプログラムをインストール

した後に、それぞれの入力欄に実行プログラムのファイルパスを  

指定してください。[Task Editor]の[Data import filter]ドロップ  

ダウンメニューにそれらが表示され、選択することができるように 

なります。 

DIA-Umpire, RawConverter(Scripps)、pXtractは、rawデータを

通常の変換とは異なる特殊な前処理(DIA→DDA 変換など)を行うプログラムです。他の通常の変換プログラム同様、必要に応じて

プログラムのファイルパスを指定してください。 

図 4-2 [Intranet]タブ 

図 4-3 [Data import filters]タブ 
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Windows のコマンドライン実行形式プログラムであれば、フィルタプログラムとして[Data import filter]タブに追加する事ができ

ます。詳しくは Mascot Daemon のメニューバー[Help]→[In Depth]→[Data Import Filter]→[Add a new filter]をご覧ください。 

 

 

(3) [ODBC connection]タブ 

Mascot Daemon と Task database ファイルをどのように接続す

るかを定義します。Database engine、ODBC ドライバー、Task 

database ファイルパスの組み合わせになりますが、詳しい構成方法

に関しては Mascot Daemon のメニューバー[Help]→[Getting 

Started]→[Database Engines]をご覧ください。  

 

 

 

 

 

 

(4) [Timer settings]タブ 

Mascot Daemon の応答時間を変更することができますが、設定

値によってはMascot DaemonによってPCのリソースが消費され、

PC の操作性が低下することがありますので注意してください。 

[Timer tick interval] 

タスクは独自のタイマーを持っており、ここで設定した時間

間隔毎にタスクの進捗状況をチェックします。この動作は PC

のリソースを消費するため、短い時間は設定しないでくださ

い。設定範囲は 1～60、推奨値は 10 です。 

[Delay after opening empty dataset] 

フィルタプログラムからの出力が無くなってからの時間を指

定します。動作に問題がなければ 0 を指定することもできま

す。設定範囲は 0～3600、推奨値は 10 です。 

[File size must be constant for at least] 

リアルタイムモニター・モードにおいて、質量データファイルの作成プロセスが完了したかどうかのチェック間隔時間を指定し

ます。推奨値は 60 です(10 以下の値は設定しないでください。逆に、60 でエラーが発生する場合はこの値を大きくしてくだ

さい)。 

[Minimum delay between monitor searches] 

リアルタイムモニター・モードにおいて、指定した質量データファイルの存在チェック間隔時間を指定します。推奨値は 60 で

すが、ファイル群の存在場所(ローカルディスクあるいはネットワーク上のディスク)やワイルドカードにマッチするファイル数に

よって最適値は異なります。ローカルディスク上に存在する少数のファイルに対しては 10 程度の値で問題ありません。 

[Minimum delay between follower searches] 

フォローアップ・モードにおいて、質量データファイルの存在チェック間隔時間を指定します。推奨値は 60 です(動作に問題

がなければ 60 未満の値を設定することができます)。 

[Take action polling interval] 

Mascot Daemon Service プログラムがタスク・データベース(TaskDB.mdb)をチェックする時間間隔です。推奨時間は 15

秒です(10 以下には設定しないでください)。 

図 4-4 [ODBC connection]タブ 

図 4-5 [Timer settings]タブ 
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(5) [Authentication]タブ 

Mascot Server のセキュリティー設定が有効になっており、ユーザ

名とパスワードでログインする必要がある場合は[Mascot Security] 

フレームにその内容を入力してください。他のユーザ名でも検索する

ことができるユーザ権限を設定している場合は、[Task Editor]タブの

[Owner]フレームがアクティブになり、ドロップダウンリストから許可さ

れたユーザ名を選択することができます。 

Web サーバがユーザ名とパスワードを要求するように設定されてい

る場合は[Web Server Authentication]フレームにその内容を入力  

してください。同様に、プロキシサーバがユーザ名とパスワードを要求

するように設定されている場合は[Proxy Server Authentication]フレ

ームにその内容を入力してください。 

 

(6) [General]タブ 

検索パラメータをテキストファイルとして保存するか、Task 

databese に格納するかを選択することができます。 

Mascot Distiller は CPU リソースのすべてを使ってピーク抽出処理

や定量計算を実行するため、Mascot Daemon の反応が鈍くなります

ので、「Below normal」または「Low」を選択して Mascot Distiller の

CPU リソース使用優先度合いを下げることができます。 

 

 

 

 

4.3 [Parameter Editor]タブ 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

検索条件を設定し、設定した内容を検索条件ファイル(*.par)として保存します。作成した検索条件ファイルは[Task Editor]タブの

[Parameter set]フレームで使用します。Mascot Daemon を起動すると自動的に default.par ファイルが読み込まれ、その内容が検

索条件として反映されます。 

 

図 4-6 [Authentication]タブ 

 

図 4-7 [General]タブ 

図 4-8 [Parameter Editor]タブ 
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(1) [Parameter set]フレーム 

[Filename] 

現在読み込まれている検索条件ファイル名が表示されます。 

[New]ボタン 

表示されている検索条件を破棄し、新たに検索条件を設定したい場合に押してください。 

[Open …]ボタン 

すでに保存してある検索条件ファイルを読み出したい場合に押してください。 

[Save]ボタン 

表示されている検索条件を default.par ファイルとして保存したい場合に押してください。 

[Save As …]ボタン 

表示されている検索条件を新しいファイル名で保存したい場合に押してください。 

 

(2) [All Searches]フレーム 

PMF 検索および MIS 検索に共通する検索条件を指定します。 

[User name]、[User email] 

ユーザ名、電子メールアドレスを入力してください。Mascot セキュリティーが有効になっている場合は次のタグを使用する

ことができます。なお、タグを構成する文字は大文字小文字を区別します。 

<mascot_user_name>：ユーザ名に置き換えます。 

<mascot_user_full_name>：ユーザのフルネームに置き換えます。 

<mascot_user_email>：ユーザの電子メールアドレスに置き換えます。 

[Search title] 

ここで入力した内容は検索結果ページの[Search title]行に表示されます。また、次のタグを使用することができます。

<mascot_user_*>(*=id, name, full_name, email)は Mascot セキュリティーが有効になっている場合に機能します(Mascot

セキュリティーが無効の場合は、検索結果ページの対応する行はブランクになります)。なお、タグを構成する文字は大文字小

文字を区別します。 

① <taskname>：タスク名に置き換えます。 

② <parameters>：検索条件ファイル名に置き換えます。 

③ <localhost>：PC のホスト名に置き換えます。 

④ <localuser>：Windows ログインユーザ名に置き換えます。 

⑤ <datafilename>：質量データファイル名に置き換えます。 

⑥ <datafilepath>：質量データファイルパス名に置き換えます。 

⑦ <cachedpeaklist>：フィルタプログラムが作成するピークリストファイルパス名に置き換えます（存在する場合）。 

⑧ <samplenumber>：サンプル番号に置き換えます(存在する場合)。 

⑨ <mascot_user_id>：ユーザ ID に置き換えます。 

⑩ <mascot_user_name>：ユーザ名に置き換えます。 

⑪ <mascot_user_full_name>：ユーザのフルネームに置き換えます。 

⑫ <mascot_user_email>：ユーザの電子メールアドレスに置き換えます。 

[Taxonomy] 

検索対象としたい生物種を選択してください。 

[Report Top] 

検索結果ページに表示させたいヒットしたタンパク質数を選択してください。 

AUTO を選択した場合は、有意なスコアを持つタンパク質が表示されます(「Protein Summary Report」の表示モードでは、

有意なスコアを持つタンパク質と、閾値スコアを超えない閾値スコアに最も近いタンパク質を表示しますので、有意なスコア持

つタンパク質が得られない検索結果においては、最も高いスコアを持つタンパク質を表示します)。 



Mascot Daemon 2.8 取扱説明書 | 21 
  

                                            
マトリックスサイエンス株式会社 

[Database] 

検索対象としたい配列データベースを選択してください。[Ctl]キーを押しながら複数の配列データベースを選択することが

できます。 

[Enzyme] 

タンパク質を消化するために使用した消化酵素を指定してください。 

「None」を選択した場合は、全ての「部分アミノ酸配列(sub-sequence)」に対して(すなわち、全ての切断特性を考慮して)検

索を実行しますので、検索対象となるペプチドの数は「Trypsin」の場合と比較して数桁多くなるため、検索時間は増加し、閾値

スコアは相対的に高くなります。HMC ペプチドのような、消化酵素由来ではない生体内ペプチドに対して検索したい場合は

「None」を選択してください。 

「Trypsin」などの消化酵素を指定した検索で有意なタンパク質がヒットしないときは、「None」を選択する前に

「semiTrypsin」を選択して再検索するほうが効率的です。「semiTrypsin」は「Trypsin」と「None」の中間的な切断特性を持っ

ており、K および R の C 末側で切断し(K および R の次に P が存在する場合は切断しません）、N 末端側は任意に切断します。

C 末端、N 末端で任意に切断されていると考えられる場合は「None」を選択してください。 

注意：CNBr を選択した場合は、Variable modifications リストから「Met->Hsl(Homoserine lactone)」あるいは「Met-

>Hse(Homoserin)」を選択してください。 

[Max. Missed Cleavages] 

ペプチドの未切断サイト数を選択してください。 

酵素消化によって得られたペプチド混合物の中に未消化サイトを持つペプチドが存在する場合は、そのサイト数(実験条件に

もよりますが、通常は「１」あるいは「２」程度)を選択してください。タンパク質が完全に酵素消化され、試料中に不完全に消化

されたペプチド断片は存在しないと断言できる場合は「０」を選択してください。検索対象となるペプチド数がより少なくなる

ため、閾値スコアは相対的に小さくなります。明確な理由なしに大きな値を選択するのは避けてください。値が大きくなるほ

ど検索対象となるペプチド数は増加し(したがって検索時間も増加し)、閾値スコアは相対的に高くなります。 

[Select Modifications] 

[Select Modifications]ボタンを押すと図 4-9 に示すダイア

ログが表示されます。左側の修飾リストから目的の修飾を選

択 し 、 [Fix Modifications] 欄 あ る い は [Variable 

Modifications]欄の左横にある[ ＞ ]ボタンを使って移動し

てください。[ ＜ ]ボタンで元に戻すことができます。 

Mascot Server は 、 化 学 修 飾 に 対 応 す る 「 Fixed 

modifications」と翻訳後修飾あるいは偶発的な修飾に対応す

る「Variable modifications」とを区別しています。 

[Fixed modifications]として指定されたアミノ酸残基また

はアミノ酸末端は、すべてその修飾を受けたものとして検索が

実行されます。たとえば、「Carboxymethyl (C)」を選択した場

合は、システインの質量(103 Da)は修飾を受けた質量である

161 Da(103-1+59)として検索が実行されます。アミノ酸残基またはアミノ酸末端は、その修飾を受けた時の質量で固定され

ますので、検索時間の増加はありません。 

一方、[Variable modifications] として指定されたアミノ酸残基またはアミノ酸末端は、その修飾を受ける場合と受けない

場合の２通りを考慮した検索が実行されます。たとえば、「Oxidation (M)」を選択した場合、もしペプチドの中に３つのメチオニ

ンが存在するときは、０、１、２、３個の酸化メチオニン残基の存在を考慮し、質量データに最もよく一致する検索結果を表示し

ます。[Variable modifications]を加味した検索はタンパク質同定においては非常に強力な手法ですが、選択する修飾の数に

比例して検索対象となるペプチドの数が幾何級数的に増加し(検索時間も級数的に増大し)、閾値スコアは相対的に高くなるた

め、有意な同定結果が得にくくなります。一般的に、試料に含まれるペプチドのうち一部のペプチドが翻訳後修飾を受けてい

ると考えられますので、第１段階の検索では、[Variable modifications]の選択数をゼロまたは最小限にとどめて、まず試料に

含まれると思われる有意なタンパク質を同定し、第２段階の検索で、同定したタンパク質に対して構造解析を行うという検索

プロセスがより効率的です。 

図 4-9 [Select Modifications]ダイアログ 



Mascot Daemon 2.8 取扱説明書 | 22 
  

                                            
マトリックスサイエンス株式会社 

なお、デフォルトの状態では代表的な修飾がリストに表示されています。Mascot Server に設定されている全ての修飾を表

示させたい場合は[Show all modifications]をチェックしてください。 

[Decoy database] 

Decoy データベースに対する検索を自動実行させたい場合はチェックしてください。主に FDR(False Discovery Rate)を確

認したいときに使用します。詳しくは次のページをご覧ください。 

     http://www.matrixscience.com/help/decoy_help.html 

[Protein Mass] 

指定した質量以下の連続したアミノ酸配列に対して検索を実行します。入力欄が空欄の場合はこの機能は無効です。たとえ

ば、10,000 Da を指定した場合は、10,000 Da の「長さ」を持つウインドウが配列データベース上を移動するイメージになりま

す。従いまして、検索対象は、分子量１万以下のタンパク質エントリと、分子量が 1 万以上のタンパク質エントリに対しては質量

値が 1 万以下の連続した部分アミノ酸配列となります。 

[Peptide Charge] 

通常は使用しません。質量データにプリカーサイオンの電荷情報が含まれない場合は対応する電荷を選択してください。 

[Monoisotopic / Average] 

質量データがモノアイソトピック(12 C)の場合は[Monoisotopic]を、平均値の場合は[Average]を選択してください。 

[Peptide tol. ±] 

ペプチド分子またはイオンの質量誤差を指定してください。次の単位をサポートしています。 

① % 

② mmu (milli-mass units、0.001Da) 

③ ppm 

④ Da 

[#13C] 

抽出されたピークがモノアイソトピック(12 C)ではなく「13 C」あるいは「13 C 2」が含まれる場合にはリストから１または２を選

択してください。質量誤差は、 

   質量誤差 ＞ ｜実験値－理論値－1 または 2｜ 

で計算されます。 

(3) [MS/MS]フレーム 

MIS 検索の検索条件を指定します。 

[MS/MS Ions Search] 

チェックすると MIS 検索が有効になります。 

[Data format] 

質量データファイルのファイルフォーマットを指定してください。次のファイルフォーマットをサポートしています。 

① Mascot generic (.MGF) 

② Finnigan (.ASC) 

③ Micromass (.PKL) 

④ Sequest (.DTA) 

⑤ mzData (.XML) 

⑥ mzML (.mzML) 

[Quantitation] 

定量解析手法を選択してください。 

[Error tolerant search] 

Error Tolerant 検索を自動実行させたい場合はチェックしてください。なお、次の制限がありますので注意してください。 

① 消化酵素を指定しなければいけない。 
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② 「Variable modification」の指定数は２個まで(設定ファイル「mascot.dat」中で変更することができます）。 

③ Quantitation 検索との併用はできない。 

[MS/MS tol. ±] 

プロダクトイオンの質量誤差を指定してください。次の単位をサポートしています。 

① mmu（milli-mass units、0.001Da） 

② Da 

[Target PSM FDR] 

FDR を同定基準として検索したい場合に利用します。現在各種論文で”1%”が採用されることが多いため 1%でのご利用を

お勧めしています。Decoy 項目にチェックが入っているときのみ利用可能です。 

[Instrument] 

質量分析計のタイプを選択してください。質量分析計のタイプに対応するプロダクトイオンの種類(イオンシリーズ)について

は次のページをご覧ください。 

http://www.matrixscience.com/help/search_field_help.html#INSTRUMENT 

[Crosslinking] 

クロスリンクの解析手法を選択してください。定量解析手法同様、使用時には予め MASCOT Server 上で設定を作成してパ

ッケージ化しておく必要があります。 

4.4 [Task Editor]タブ 

 

 

 

 

 

 

 
タス

クを作成し、Mascot 検索を実行します。 [Task]フレームの入力欄(デフォルトは「Untitled」）に文字列を入力してタスク名を設定して

ください。それぞれのタスクにはタスク ID（通し番号）が付けられます。タスク名は[Status]タブおよび[Event Log]タブ内でタスク ID

とともに表示されます。タスクには次の 3 種類の動作モードがあり、それぞれ[Data file list]フレームのレイアウトが異なります（図 4-

10 はバッチ・モードのフレームレイアウトです）。 

図 4-10 [Task Editor]タブ 
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バッチ・モード (batch) 

指定した(１つまたは複数の)質量データファイルをひとつずつ、順番に Mascot 検索を実行します。Mascot 検索開始日時を指

定したり、複数タスクを順序よく実行させることも可能です。 

リアルタイムモニター・モード (Real-time monitor) 

指定したフォルダ（ローカルあるいはネットワーク上）を監視し、そのフォルダに新たに作成された質量データファイルを取得し、

Mascot 検索を実行します。すなわち、質量分析計のデータ処理ソフトウェアが作成した質量データは、Mascot Daemon を介して

自動的に Mascot Server に投入されますので、タンパク質同定にかかわる質量データ処理プロセスを自動化することができます。 

フォローアップ・モード (Follow-up) 

検索結果のスコアあるいは期待値が、あらかじめ指定した条件に達しなかった場合、別の検索条件で再検索を実行します。 

 

(1) [Owner]フレーム 

Mascot セキュリティーが有効になっており、他のユーザ名でも検索することができるユーザ権限を設定している場合にアクテ

ィブになります。ドロップダウンリストからユーザ名を選択してください。 

 

(2) [Task]フレーム 

入力欄（デフォルト値は「Untitled」）にタスク名を入力してください。ここで入力したタスク名は[Status]タブ、[Event Log]タブ、

検索結果ページの[Search title]行に表示されます。[Status]タブ内に表示されているタスクの「Clone」を作成した場合は、タスク

名の前に「Copy of」が加えられます。[New]ボタンは設定内容をデフォルトに戻します。[Run]ボタンを押すとタスクが実行されま

す。 

 

(3) [Parameter set]フレーム 

[…]ボタンを押して、[Parameter Editor]タブで作成・保存された検索条件ファイル（*.par）を読み込んでください。検索条件フ

ァイルが保存されるデフォルトのフォルダは「C:¥ProgramData¥Matrix Science¥Mascot Daemon¥parameters」です。 

(4) [Data import filter]フレーム 

 

質量データファイルが raw データ、質量分析計ベンダー独自のバイナリ形式（拡張子が .raw や .wiff など）の場合、対応する 

フィルタプログラムを使って質量ピーク抽出処理を行った後に Mascot 検索を実行する必要があります。ドロップダウンリスト  

から質量データファイルに対応するフィルタプログラムを選択し、その右にある[Options …]ボタンを押してください。ピーク抽出

などの処理条件を設定するためのダイアログが表示されますので、処理条件を設定した後、[OK]ボタンを押してください。[Run]

ボタンを押すと、質量データファイルはフィルタプログラムでピーク抽出処理され、作成されたピークリストが Mascot Server に

投入されます。デフォルトでは次のフィルタプログラムをサポートしています。 

 

 

 

 

[次頁に続きます] 
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① Mascot Distiller 

Mascot Daemon がインストールされている PC に

Mascot Distiller がインストールされている場合に表示

されます。全ての質量分析計ベンダーの質量データファ

イルを処理することができます。 

「Mascot Distiller」を選択した後、[Options …]ボタ

ンを押すと図 4-11 に示すダイアログが表示されますの

で、[Data File Format]フレームから質量データファイ

ルのファイルフォーマットを選択し、[…]ボタンから適切

な処理条件ファイル（Processing Options ファイル：

*.opt）を読み込んでください。[Multi-Sample Files]フ

レームは AB | MDS Sciex の Analyst .WIFF ファイル

用の設定項目です。WIFF ファイルが複数のサンプルデ

ータから構成されている場合の検索方法(統合か個別

か)を指定することができます。[Scan Range (multi-

scan files)]フレームでは、データ処理の範囲を LC の保

持時間や質量分析計のスキャン番号で指定することが

できます。[Output MS/MS Fragment as]フレームでは、出力データとしてのプロダクトイオンの電荷を指定することがで

きます。Mascot Server はプロダクトイオンの電荷を１価あるいは２価と仮定して検索しますので、３価以上のプロダクトイ

オンが存在する場合は「MH+」を選択し、多荷のプロダクトイオンのm/z値を１価の質量に変換して出力するようにしてくだ

さい。[Distiller Project File]フレームの[Save]をチェックすることにより、Mascot Distiller の処理内容をプロジェクトファ

イル(*.rov)として自動的に保存します。定量計算を行った場合は、計算対象となるタンパク質の範囲（[Range]の場合はヒッ

ト番号）を指定してください。 

 

② ProteoWizard msConvert 

 Mascot Daemon がインストールされている PC に

ProteoWizard msConvert がインストールされおり、メニューバ

ー[Edit]→ [Preferences]→[Data import filters]タブの[Full 

path to ProteoWizard msConvert]入力欄にそのファイルパス

が指定されている場合に表示されます。様々なフォーマットの

質量データファイルを処理することができます。 

http://proteowizard.sourceforge.net/doc_users.html 

[Data import filter]から「ProteoWizard msConvert」を選択

した後、[Options …]ボタンを押すと図 4-12 に示すダイアログ

が表示されますので、適切な処理条件を設定し、[OK]ボタンを

押してください。入力する質量データファイルのフォーマットは

自動で認識され、「MGF」あるいは「mzML」のフォーマットで出

力されます。詳しくは Mascot Daemon のメニューバー[Help]

→[Mascot Daemoon Help]→[In Depth] →[Data Import 

Filters]→[ProteoWizard msConvert]の項をご覧ください。 

 

＊基本的に MASCOT Daemon をご利用される際には、”Peak list format”の項目について “MGF”を選択した上で

ご利用ください。 

 

 

図 4-11 Mascot Distiller 

図 4-12 ProteoWizard msConvert 
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③ Thermo ExtractMSn  

詳しくは Mascot Daemon のメニューバー[Help]→[Mascot Daemoon Help]→[In Depth]→[Data Import Filters]→

[Thermo ExtractMSn]の項をご覧ください。また併せて次のページもご覧ください。 

http://www.matrixscience.com/help/instruments_xcalibur.html 

 

④ AB SCIEX MS Data Converter 

詳しくは Mascot Daemon のメニューバー[Help]→[Mascot Daemoon Help]→[In Depth] →[Data Import Filters]→

[AB Sciex MS Data Converter]の項をご覧ください。また併せて次のページもご覧ください。 

http://www.matrixscience.com/help/instruments_analyst.html#Converter 

 

(5) [Data file list]フレーム 

 

タスクの種類(動作モード)により、フレームレイアウトが異なります。 

①  バッチ・モード 

[Schedule]フレームの[Start now]または[Start at]また

は[Start on completion of]が選択されている場合の動作

モードです。ひとつまたは複数の質量データファイルに対

して、逐次的に Mascot 検索を実行します。[Start on 

completion of]では、指定した検索中ないし予定されてい

るバッチ・モードの検索が終わった後に Mascot 検索を実

行します。質量データファイルは[Add Files …]ボタンを押

して表示されるダイアログから指定してください。[Data 

import filer]でフィルタプログラムを選択した場合は[Add 

Folder …]ボタンも有効になり、「Masslynx」、「Bruker 

XMASS/XTOF」、「Bruker Esquire」、「Agilent LC/MSD 

Trap」などのフォルダ単位の質量データを指定することが

できます。また、Windows のファイルブラウザ上で選択したファイル群またはフォルダ群を[Data file list]ウインドウにドラ

ッグ＆ドロップすることもできます。 

[Data file list]ウインドウに読み込んだ質量データファイルまたはフォルダを削除する場合は、削除したいファイルまた

はフォルダを選択し、[Delete]ボタンを押してください。 

[Merge MS/MS files into single search]をチェックすると、[Data file list]ウインドウにある全ての質量データファイ

ルを結合してひとつにし、Mascot検索を実行します(XML形式のデータファイルは統合できません)。[Data import filter]

でフィルタプログラムが指定されているときは、フィルタプログラムによって処理された質量データファイルが

「C:¥ProgramData¥Matrix Science¥Mascot Daemon¥MGF¥タスク名¥mascot_daemon_merge.mgf」ファイルとして

統合されます。なお、フィルタプログラムとして「Mascot Distiller」を指定したときは、[Status]タブには Mascot Distiller 

Project ファイルのリンクは表示されませんが、各質量データファイルに対するプロジェクトファイルは

「C:¥ProgramData¥Matrix Science¥Mascot Daemon¥MGF¥タスク名」フォルダに保存されています。 

フィルタプログラムとして「AB SCIEX MS Data Converter」を指定したときは、[Add Folder …]ボタンではなく[Job 

Run …]ボタンになります。[Job Run …]ボタンを押すとテキストを入力するためのダイアログが表示されますので、

「4800¥ProteinPilot Getting Started Guide¥iTRAQ Reagents - 8Plex 8 Protein Mix¥3¥1¥2」のような Pseude パスを入

力してください。 

② リアルタイムモニター・モード 

図 4-13 [Start now/at/on completion of]モードのフレーム 

http://www.matrixscience.com/help/instruments_xcalibur.html
http://www.matrixscience.com/help/instruments_analyst.html#Converter
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[Schedule]フレームで[Real-time monitor]が選択され

ている場合の動作モードです。リアルタイムモニター・モー

ドでは、ワイルドカードを含むフォルダパスやファイルパス

を使って質量データファイルを指定します。[New files 

only]をチェックすると、タスクを実行した時点ですでに存

在した質量データファイルは無視されます。[Include sub-

folders]をチェックすると、[Specify path to root folder]

欄で指定したフォルダおよびそのサブフォルダに存在する

質量データファイルに対して検索を実行します。 

なお、ワイルドカードにより指定されるファイル数は非

常に多くなる場合がありますので、もしタスクを実行した

後に指定内容の間違いに気づいた場合はそのタスクを強

制終了してください([Status]タブに移動し、対応するタスク名を右クリックし、[Pause]を選択した後に[Delete]を選択し

てください)。 

ワイルドカード(「*：任意個の文字」および「?：１個の文字」)の使用例を示します。[Specify path to root folder]欄で

「D:¥Data¥P*¥Q*¥200311??」のように指定した場合、 

D:¥Data¥Proteins¥QStar¥20031102 

D:¥Data¥Peptides¥QTrap¥20031103 

などのフォルダパスが対象となりますので、[Optional wild card file or name]欄で「*.wiff」を指定することにより、こ

れらの指定内容に一致する次のような質量データファイルが検索対象となります。 

 D:¥Data¥Proteins¥QStar¥20031102¥Trypsin234.wiff 

質量データファイルを含むフォルダを対象としたい場合、たとえば、 

 D:¥Data¥Proteins¥QTof¥Default.pro¥Data¥Trypsin234.raw 

フォルダの場合は、[Specify path to root folder]欄で「D:¥Data¥Proteins¥QTof¥*.pro¥Data」を、[Optional wild 

card file or name]欄で「*.raw」のように指定することができます。しかし、[Specify path to root folder]欄で

「D:¥Data¥Proteins¥QTof¥*.pro¥Data¥*」を指定し、[Optional wild card file or name]欄を空欄にした場合は、対象と

なるフォルダ階層が深すぎるため（すなわち「D:¥Data¥Proteins¥QTof¥*.pro¥Data¥*¥*」を指定することになり）、動作

しません。 

[Include sub-folders]をチェックした場合は、[Specify path to root folder]欄で指定したフォルダ及びそのサブフォル

ダに存在する質量データファイルが検索対象となりますが、検索対象がフォルダの場合は動作しません。 

なお、「AB SCIEX MS Data Converter」を使って Oracle データベースから取得した TOF/TOF データに対しては、動作

しません。 

③ フォローアップ・モード 

[Schedule]フレームで[Follow-up]が選択されている場

合の動作モードです。フォローアップ・モードで作成・実行

されたタスクは「アイドリング状態」で待機し、他のタスクで

指定されたフォローアップ条件に合致した結果として回さ

れてきた質量データファイルに対して Mascot 検索を実行

しますので、[Data file list]フレームは使いません。複数の

フォローアップ・タスクを組み合わせ、より複雑な検索処理

プロセスを作成することができます。 

 

 

 

図 4-14 [Real-time monitor]モードのフレーム 

 

図 4-15 [Follow-up]の[Data file list]フレーム 
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(6) [Schedule]フレーム 

 

タスクの種類(動作モード)を指定します。 

[Start now]と[Start at]と[Start on completion of]はバッチ・モードに対応します。[Start now]はタスクをすぐにスタート  

させます。[Start at]はタスクを時間指定して開始します。[Start on completion of]は、指定したタスクが完了した後にタスクを

実行するように指定します。 

[Real-time monitor]はリアルタイムモニター・モードに対応します。 

[Follow-up]はフォローアップ・モードに対応します。 

[Search priority]は実行したタスクの優先順位を指定します。[0]から[-20]の値を指定することができ、数値が小さいほど優

先順位が低くなります。 

 

(7) [Actions]フレーム 

 

[Auto-export]ボタンを押すと、図 4-16 に示すダイアログが表示

されます。[Choose first]で検索モード（PMF または MS/MS）を、

[Choose second]で出力フォーマットを選択し、[Format]フレーム

で出力したい項目をチェックした後、ページの最後にある[OK]   

ボタンを押してください。Mascot検索が終了した後に、指定された

出力フォーマットで検索結果の内容が「C:¥ProgramData¥Matrix 

Science¥Mascot Daemon¥MGF¥タスク名」フォルダにファイル 

出力されます。なお、出力項目は Mascot 検索が実行される前に 

設定されていますので、Mascot 検索結果がその出力項目を含まな

い場合はエラーが返されることがあります。Mascot 検索の条件や

内容を考慮して出力項目を選択してください。 

 

[External processes] ボ タ ン を 押 す と [Mascot Daemon 

External processes]ダイアログが表示されます。動作させたい外部プログラムを、 

① タスクの開始前 (Before starting task) 

② 検索の実行前 (Before each search) 

③ 検索終了時 (After each search) 

④ タスクの終了時 (After completing task) 

の各タイミングで指定し、実行させることができます。なお設定した内容はタスクの構成情報としてタスク毎に記録されます。 

[Wait for completion]をチェックした場合は、外部プログラムが終了するのを待つことになりますが、もし外部プログラムが 

正常終了せずに固まった状態（hung）になった場合は、タスクはそれに引きずられ先に進みません。もし、外部プログラムがエラー

を出力して停止した場合は、そのエラーは Event Log 欄に出力され、Task は次のステップへと進行します。 

[Halt on error]をチェックした場合は、外部プログラムがエラーを出力して停止した時点でタスクは途中終了します。 

なお、External processes 機能は Mascot Daemon Engine プログラムが管理しています。もし、Mascot Daemon Engine  

プログラムをWindowsのサービスプログラムとして動作させていて、外部プログラムがデスクトップ・アプリケーションの場合は、

Mascot Daemon Engine サービスプログラムがこの外部プログラムを実行できるように設定してください。 

 

External processes では次のタグを変数のように使用することができます。<resulturl>タグのように、処理が終了するまで値

を持たないものがあります。また、タグは大文字小文字を区別します。 

 

 

 

図 4-16 Auto-export の詳細設定 
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<taskname>：タスク名 

<parameters>：検索条件ファイルパス 

<localhost>：コンピュータ名 

<localuser>：ログオンユーザ名 

<datafilename>：質量データファイル名 

<datafilepath>：質量データファイルパス 

<cachedpeaklist>：「Data import filter」プログラムが作成したピークリストファイルパス 

<samplenumber>：サンプル番号 

<mascot_user_id>：Mascot セキュリティユーザ ID 

<mascot_user_name>：Mascot セキュリティユーザ名 

<mascot_user_full_name>：Mascot セキュリティユーザフルネーム 

<mascot_user_email>：Mascot セキュリティユーザメールアドレス 

<resulturl>：検索結果ページ URL 

<resultfilename>：検索結果ファイル名 

<resultfilepath>：検索結果ファイルパス 

External processes の設定例を示します。図 4-17 の上段に示した設

定の下でタスクを実行すると、タスクが開始される前に、net コマンドを

使って PC のログインユーザである「<localuser>」に「タスク名 is 

starting」のメッセージを送り(PC のディスプレイ上にはこのメッセージ

を含むダイアログが表示されます)、Mascot 検索が終了した時点で検索

結果ページを読み込んだブラウザが起動し、タスクが終了した時点で

「<localuser>」に「タスク名 has finished」のメッセージを送ります。な

お、Web ブラウザはデスクトップ・アプリケーションですので、Mascot 

Daemon Engine プログラムがサービスプログラムとして動作している

場合は、デスクトップ・アプリケーションを実行できるように設定してくだ

さい。 

図 4-17 の下段は「Microsoft Windows Script」を使用した例です。上

段の例と同様に、タスクを実行すると、タスクの開始時及び終了時に net

コマンドを使って PC のログインユーザである「usami」にメッセージ(「タ

スク名 is starting」と「タスク名 has finished」)を送りますが、同時に

「C:¥temp¥links.txt」ファイルが作成され、各々のMascot検索に対する

検索結果ページのURLが一行ずつ追加されていきます。ここで使用した

simple.vbs スクリプトは次のような内容を持っています。また、ここで使

用したスクリプトはデスクトップ・アプリケーションではありません。 

<スクリプトファイル名：simple.vbs> 

Option Explicit 

'Result file name and result URL are passed as command line arguments 

Dim objArgs, ResultFileName, ResultURL 

Set objArgs = WScript.Arguments 

ResultFileName = objArgs(0) 

ResultURL = objArgs(1) 

'Format result URL as hyperlink and append to links file 

Dim fso, MyFile, ForAppending 

ForAppending = 8 

Set fso = CreateObject("Scripting.FileSystemObject") 

Set MyFile = fso.OpenTextFile("c:¥temp¥links.txt", ForAppending, True) 

MyFile.WriteLine "<A HREF=" & CHR(34) & ResultURL & CHR(34) & ">" & ResultFileName & "</A>" 

図 4-17 [External processes]の設定例 
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(8) [Follow-up]フレーム 

再検索を実行するための条件を設定します。 

再検索条件として[If  score less than]を選択してスコアの値

を、[If  probability that match in random > 1]を選択して期待

値の値(0.05 を指定したい場合は 20 を入力)を設定します。検索

結果のスコアが指定値を下回った場合(検索結果の期待値がその

値を上回った場合)に、その質量データファイルは[Repeat at 

intervals of]で指定した時間間隔で再検索されるか、あるいは

[Pass data to]で指定した(あらかじめ実行してある)フォローアッ

プ・タスクに渡され、その検索条件に従って再検索されます。 

フォローアップ機能は様々な目的に利用することができます。 

(例１) 設定したスコアまたは期待値に達しなかった質量データファイルに対し、指定した時間間隔で再検索させるようにす

ることができます。再検索は設定条件を満たさなくなるまで無期限に続けられます。データベースが定期的に更新

される場合などに有効です。 

(例２) ひとつの質量データファイルに対して、異なる複数の配列データベースを検索させることができます。たとえば、最

初に NCBInr データベースを検索させ、設定したスコアあるいは期待値に達しなかった場合は dbEST データベー

スを再検索させることができます。 

[Discard results]をチェックすると、[Status]タブの検索結果ツリーには各々の検索結果は追加されなくなりますが、設定した

スコアあるいは期待値に達しなかった検索の場合は、[Event Log]タブにその内容を伝えるメッセージ（たとえば「Search results 

discarded (score is less than 61 specified threshold)」)が表示されます。 

[Repeat at interval of]をチェックすると、設定したスコアあるいは期待値に達しなかった質量データファイルは指定した間隔

(分、時間、日、週、月)で再検索されます。 

[Pass data to]をチェックすると、設定したスコアあるいは期待値に達しなかった質量データファイルはリストから選択したフォ

ローアップ・タスクに渡され、再検索されます（フォローアップ・タスクはあらかじめ実行し、“アイドリング状態”にしておく必要があ

ります）。 

4.5 [Event Log]タブ 

[Event Log]タブには Mascot Daemon が実行したイベントに関するログ情報が表示されます。warning や error に関するメッセ

ージもここに表示されます。表示されるログ情報は Mascot Daemon が起動した時点から始まります。過去のログはカンマで区切ら

れた CSV ファイルの形式で次のファイルに記録されます。なお、Mascot Daemon Service プログラムの出力メッセージは Windows 

Event Log に記録されるもこともありますので、必要に応じて確認してください。 

C:¥ProgramData¥Matrix Science¥Mascot Daemon¥Mascot_Daemon_Event_Log.csv 

 

図 4-18 [Follow-up]フレーム 

図 4-19 [Event Log]タブ 
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4.6 [Status]タブ 

[Status]タブでは、[Task Database]、[タスク名]、[質量データファ

イル名]の関係をツリー構造で表示するとともに、タスクの状態や  

検索結果の概要を確認することができます。 

左側ウインドウの最上位に位置する[Task Database]を選択する

と、右側ウインドウにはそれに含まれるタスクに付随する情報が一覧

表示されます。左側ウインドウの[タスク名]を選択すると、右側ウイン

ドウにはそれに含まれる検索概要(質量データファイル名や検索結果

URLなど)がリスト表示されます。左側ウインドウの[質量データファイ

ル名]を選択すると、右側ウインドウにはその検索の概要が表示され

ます。なお、右側ウインドウの最上位にあるタイトルカラムをクリック

すると、表示されているリストの並びを昇順・降順に切り替えること

ができます。また、タイトルカラムの幅は境界線をマウスでドラッグす

ることにより変更することができます。 

タスクの状態は、タスク名の左側にあるアイコンで確認することができます。各アイコンは次の意味を持っています。 

 

タスクは一時停止(Pause)、再検索(Resume)、複製(Clone)、削除(Delete)することができます。タスク名を右クリックし、表示され

たリストから実行したい操作を選択してください（あるいは、タスク名をクリックし、下方に配置されているボタンを押してください）。 

[Clone]を選択することにより、そのタスク情報は[Task Editor]タブに「Copy of  タスク名」として複製されますので、類似の条件

を持った新しいタスクを作成するときに便利です。 

[Delete]を選択してタスク全体を削除できますが、タスクにぶら下がっている個々の[質量データファイル名]を削除することは  

できません。また、タスクを削除すると Mascot Daemon が管理するタスク・データベースファイルからその情報が削除されますが、

Mascot Server が管理する結果ファイルが削除されることはありません。 

[質量データファイル名]をドラッグして、[フォローアップ・タスク名]にドロップすると、そのフォローアップ・タスクの条件で再検索

を実行することができます。 

[Status]タブの画面は[Task action polling interval (seconds)]の設定値([Edit]→[Preferences]→[Timer settings]タブ)に  

従ってリフレッシュされます。リフレッシュする毎にタスク・データベースファイルを読み込み、PC のリソースを消費しますので、この

設定値は小さくせずに、必要に応じて[Refresh (F5)]ボタンを押してください。 

ひとつのタスク・データベースファイルは異なる PC にインストールされた複数の Mascot Daemon で共有することができます。 

それぞれのタスクはそのタスクを作成した Mascot Daemon が所有者になり、タスクの一時停止(Pause)、再検索(Resume)、削除

(Delete)を行うことができますが、複製(Clone)は全てのクライアントに許可されています。  

ステータスツリーに多くのタスクがある場合、特定のタスクを見つけるのが難しい場合があります。[Filter...] ボタンをクリックする

とダイアログが表示され、様々な条件で表示をフィルタリングすることができます。ドロップダウンリストは、「--- Any ---」以外に設定

されている場合にアクティブになります、エディットボックスの場合は空でなく何か文字が記されている場合にアクティブになります。

アクティブなフィルタをすべて満たすタスクがない場合、ツリーは空になります。これは単に表示上のフィルタであることに 注意し

てください。実行中のタスクはすべて実行され続けます。すべてのフィルターを クリアするには クリア ボタンをクリックします。ダ

イアログを閉じたときにフィルターが有効になっている場合は、 ボタンのラベルが太字イタリック体で表示されます。 

：Running task（タスク実行中のアイコン） 

：Follow-up task（フォローアップ・タスクのアイコン） 

：Trying to pause a running task（タスクを一時停止させる際の待ちアイコン） 

：Completed task（タスク完了のアイコン） 

：Cancelled task（キャンセルされたタスクのアイコン） 

：Paused task（一時停止したタスクのアイコン） 

図 4-20 [Status]タブ 



Mascot Daemon 2.8 取扱説明書 | 32 
  

                                            
マトリックスサイエンス株式会社 

5 補足 

5.1 Mascot Daemon Engine を Windows のサービスとして動かす方法 

Mascot Daemon のメニューバー[Help]→[Mascot Daemoon Help]→[In Depth] →[Running Daemon as a service]の項を

ご覧ください。 

5.2 タスク・データベース 

(1) VistaDB 

VistaDB エンジンは Mascot Daemon に組み込まれていますので、Mascot Daemon をインスト－ルすれば何の設定も必要な

くそのまま利用することができます。他の Database エンジンを使う特別な理由がないようでしたら VistaDBをお使いください。 

① Task database の作成 

VistaDB の Task database ファイル「taskdb.vd5」は Mascot Daemon をインストールすると次のように自動的に作成さ

れます。 

C:¥ProgramData¥Matrix Science¥Mascot Daemon¥taskdb.vdb5 

もし、このファイルが壊れて使えなくなった場合は、次のフォルダに空の taskdb.vd5 がありますので、それをコピーしてお

使いください。 

C:¥ProgramData¥Matrix Science¥Mascot Daemon¥VistaDB 

② Task database の編集 

Task database のテーブル構造は変更することはで

きませんが、テーブルの値は変更することができます。

たとえば、Mascot Server を新しい PC に移動した場

合、もし PC のホスト名が変われば Mascot Server の

URL も変わりますので、Mascot Daemon の[Result 

file URL]行に表示されている検索結果 URL リンクはす

べてリンク切れになります。ユーティリティプログラム

「C:¥Program Files¥Matrix Science¥Mascot 

Daemon¥DBASampleTool.exe」を使って Task 

database ファイルの[Mascot_Daemon_Results]テー

ブルの値に含まれるホスト名を変更してください。 

1. Mascot Daemon を終了してください。また、タス

クトレイにある Mascot Daemon Engine も右クリ

ックして[Exit]してください。 

2.「taskdb.vd5」ファイルをバックアップしてくださ

い。 

3.「C:¥Program Files¥Matrix Science¥Mascot 

Daemon¥DBASampleTool.exe」をダブルクリックしてください。「VistaDB Table Editor」が起動します。 

4. メニューバー[File]→[Open Database]から「C:¥ProgramData¥Matrix Science¥Mascot Daemon¥taskdb.vdb5」を

開いてください。 

5. 左側のイクスプローラーから[Table]→[Mascot_Daemon_Results]→[Data]の順に選択してください。 

6. 右側ウィンドウを右の方にスクロールして[result_url]のカラムを探し、そこに記述されているホスト名を確認してくださ

い。 

7. 左側イクスプローラーの[Query]を選択してください。 

図 5-1 VistaDB Table Editor：ホスト名の確認 

図 5-2 VistaDB Table Editor：ホスト名の変更 
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8. 右側ウインドウの[Query Expression]入力欄に SQL クエリー実行文を入力してください。たとえば、「old_server」とい

うホスト名を「new_server」に変更する場合は次の実行文になります。 

     UPDATE Mascot_Daemon_Results SET result_url = 

REPLACE(result_url,'http://old_server','http://new_server'); 

9. [Execute Query]ボタンを押してください。 

10 ホスト名が正しく変更されたことを確認してください。 

11 メニューバー[File]→[Close Database]を選択してください。 

12.「VistaDB Table Editor」を終了してください。 

(2) その他のデータベース 

Access,PostgreSQL, SQL Server, mySQL,Oracle  

その他のデータベースについて、詳細は [Help]→[Mascot Daemoon Help]→[Getting Started] →[Database Engines] 

にある、それぞれの項目をご覧ください。 

5.3 Stop Mass リスト 

PMF検索の際に、あらかじめ指定した質量が質量データの中に  存

在する場合、その値を無視する「Stop Mass 機能」を利用することがで

きます。「Stop Mass 機能」を有効にするためには、次のファイルをひ

とつ上の階層の Mascot Daemon フォルダにコピーしてください。 

 

 

 

C:¥ProgramData¥Matrix Science¥Mascot Daemon¥stop_masses¥Mascot_Daemon_PMF_stop_masses.txt 

Stop Mass の指定方法は、モノアイソトピック m/z と平均 m/z をカンマ（ , ）で区切り、一行に記述します。図 5-3 に示す記述例

をご覧ください。 
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